Solved: Content lost after 10.0 upgrade

We have found the issue and released version 10.5 which will attempt to auto-fix the problem. Please upgrade and check if your notes are fine.

There is one caveat though - If you had modified a note where data is lost, it won't attempt to re-write that note. If you are in this situation and want to restore all data as earlier, please follow below steps -

The latest update disables automatic SD card backup but the backup file from your previous version should still be present. Please do the following -
  1. Connect your phone to a PC and copy the existing SD card back up file some where. From your pc, you should be able to see it as "secnotes/secnotes.db".
  2. Uninstall SecNotes from phone.
  3. Download the older 9.0 version apk file from here -
  4. Install it, start it and give file permission when asked. It will tell you there is a backup existing and if you want to restore. If you had not set any password earlier, please choose to restore.
  5. If you had set a password/pin or patter earlier, please set the same password again from "Settings" and use the "Restore from backup" to restore notes.
  6. This should restore all your notes as it was earlier.
  7. Please verify if your earlier data is visible.
  8. Upgrade to the latest version from play store. You can either do this yourself of let play store update automatically if auto-updates are set. Versions after 10.5 will upgrade without data loss.

Followed your instructions. With 9.0 APK from your Google Drive, all my spreadsheets are normal. However, after I go to the Google Play and update to the version 10.2, the problem gets back. All spreadsheets are empty.


Hi Alex, could you please let me know what phone you are using ? Thanks.

Samsung S10.

P.S. By the way are you receiving my email? (used the one from Google play)

Absolutely keeps happening to me. I definitely have lost passwords and other information. Tried your solution 3 times. Tried installing version 10 then uploading information as well. Pockets of information are gone, and my backup file was not updated. No SD card on this phone, had to use a manual backup I saved externally two weeks ago. Oneplus 8T+. Very disappointed as I've used this app and it's worked like a dream for 6 years...

Hi Tyler, I hope your notes were alright after installing 9.0? If yes, could you please try once again. We have uploaded version 10.3. So please install 9.0 from the download link, recover notes from the backup and try upgrading. This is happening in some special condition to select people. We have extensive tests to test upgrade and even restoring from older backups but they all were working fine.

It would be really great if you could try once again. I am trying to catch some error conditions so they get recorded as ANRs (errors) in google play store. It doesn't capture any of your data but says which line of code in the application caused the error to happen.

I sincerely apologize for the inconvenience but the changes were mandatory to keep the app working in newer android versions.

Uninstalled. Installed 9.0.apk, set pattern password, restored file from backup. Everything looks good at this point. Go to Play and update to 10.3, recheck and the files are missing again. Problem not fixed.

I had the same issues, but now it fixed. Download 10.5 version.

Finally I can use it. Sure was inconvenient for a week+... But I will remain a loyal user! Still a great app

Thanks for confirming @tyler :)

Application very successfully answers fast to our questions and troubleshooting. With the new update solved the problem of data loss. Thank you, friends.